Results 1 to 3 of 3

Thread: Issue: Render results always contain no background HDRI images (DAZ Studio)

  1. #1
    Join Date
    Jul 2020
    Location
    Japan
    Posts
    2

    Default Issue: Render results always contain no background HDRI images (DAZ Studio)

    Hi, all!

    I recently started using Iray Server (30 day trial) with DAZ Studio bridge.

    Almost all scenes are rendered perfectly, but scenes which contain background HDRI images (environment maps) are rendered without the images (just like transparent PNG ones), containing only IBL-shaded figures and objects, while previews on the Iray Server web console appear to be perfectly rendered without the problems.

    Click image for larger version. 

Name:	20200706_Michael_01-Beauty.png 
Views:	9 
Size:	83.0 KB 
ID:	10912

    I've tried rendering some different scenes, and always got the similar results.

    After the renderings, I checked the Iray Server logs (including worker logs), but found no errors/warnings relevant to the issue.

    Of course in DAZ Studio itself, the scenes are perfectly rendered without the issue.

    Click image for larger version. 

Name:	20200706_Michael_01.png 
Views:	9 
Size:	121.9 KB 
ID:	10913

    Has anyone experienced the similar issue? I'd really like to know the solution for this issue. Any advice would be greatly appreciated!

    [My environment] (Local machines on the same network)
    Iray Server Version 3.1 | Build 327300.6313
    OS: Windows Server 2019 Standard (Version 1809) OS Build 17763.1282
    RAM: 32GB
    CPU: Intel Core i7-4770 @3.40GHz
    GPU: nVidia GTX980 (4GB)

    DAZ Studio Version 4.12.1.118 Pro Edition (64-bit)
    OS: Windows 10 Pro (Version 1909) OS Build 18363.900
    RAM: 32GB
    CPU: Intel Core i7-7700K @4.20GHz
    GPU: nVidia GTX1080 (8GB)
    Attached Thumbnails Attached Thumbnails 20200706_Michael_01-Beauty.jpg   20200706_Michael_01.jpg  

  2. #2
    Join Date
    Dec 2017
    Location
    Melbourne, Australia
    Posts
    376

    Default

    This will depend on how DAZ3D sends the job to Iray Server in terms of which pixel type it asks for (which Iray Server doesn't control, DAZ does). However if you pause your queue before submitting the job you can edit the pixel type after submitting the job but before it renders.

    Click image for larger version. 

Name:	iray_server_edit.jpg 
Views:	11 
Size:	68.1 KB 
ID:	10914

    Selecting RGB instead of RGBA will cause the alpha channel not to be generated or saved and so you will see the background. Also note that even with the alpha channel generated the background is still there, however certain viewing tools (like Windows Picture Viewer) then don't show it. If you open the file in Photoshop (or a similar tool) and choose Layer | Layer Mask | From Transparency and then go to your Channels panel and delete the Alpha channel that appears it will reveal that background.

    As I say though, we can't do anything about what pixel format (RGB or RGBA) which DAZ requests. There might be something in DAZ3D do control this but you'd have to ask DAZ or review their documentation.

  3. #3
    Join Date
    Jul 2020
    Location
    Japan
    Posts
    2

    Default

    Thanks for quick and detailed reply!

    Now I understand the cause. Just tried again rendering with Bit Depth RGB, and got desired result.

    I'll research DAZ3D-side pixel type for even more convenient way.

    I made up my mind purchasing Iray Server subscription. Thanks again for precise answer!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •