Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Strange dark reflections

  1. #1
    Join Date
    Oct 2019
    Posts
    3

    Default Strange dark reflections

    Hoping someone can help me identify the problem here. Noticed first on similar shaped imported parts, but same thing happens to this simple shape with no smoothing and the shape is isolated in the scene.
    According to the lighting analysis it's a shadow but the dark parts behave like a reflection, moving with the camera.
    Click image for larger version. 

Name:	Cover1.JPG 
Views:	72 
Size:	111.1 KB 
ID:	10768

    Edit:
    3ds max 2020, Iray2.1
    Last edited by Anbear; 11th October, 2019 at 10:53.

  2. #2
    Join Date
    Dec 2017
    Posts
    300

    Default

    Hi

    I think it is very hard to help here, without example scene with this problem.
    It could be a problem in mesh ...

    Best!
    Nik

  3. #3

    Default

    Quote Originally Posted by Anbear View Post
    Hoping someone can help me identify the problem here. Noticed first on similar shaped imported parts, but same thing happens to this simple shape with no smoothing and the shape is isolated in the scene.
    According to the lighting analysis it's a shadow but the dark parts behave like a reflection, moving with the camera.
    Click image for larger version. 

Name:	Cover1.JPG 
Views:	72 
Size:	111.1 KB 
ID:	10768

    Edit:
    3ds max 2020, Iray2.1
    This is like my normals thing reversing. I get this too.

  4. #4
    Join Date
    Sep 2019
    Location
    Belgium
    Posts
    7

    Default

    Maybe you could upload the max-file ?

  5. #5
    Join Date
    Oct 2019
    Posts
    3

    Default

    I'm back.
    I did see the post about the odd "normals" behaviour, but I see no change when flipping them. different mesh, materials and uvw mapping makes no difference.
    No problem when using iray+ interactive.

    Attached a scene with two meshes that gives me this problem. btw this is a fresh install of 2020 and iray+,not other plugins. makes me wonder if there's something I forgot to do.. does the current iray installer do everything, or are there some manual procedure as well, like the older free version of iray?

    IPF01.zip

  6. #6
    Join Date
    Nov 2017
    Posts
    269

    Default

    Hi Anbear,

    I can reproduce the issue here and we're looking at it. Not sure at this point if it's an issue with Iray or with the model, but we'll have a look.

    Michael
    QA Engineer, Lightworks

  7. #7
    Join Date
    Nov 2017
    Posts
    269

    Default

    Hi Anbear,

    It looks like this could be a re-appearance of an old bug, or at least something similar. Either way, you can work around the issue by disabling instancing in Iray. This will fix the issue, but can lead to increased memory usage on the GPU so you may not be able to do this if you are close to the memory limit on your card either way.

    If you want to try it, the details of how to switch off instancing are here - https://www.irayplugins.com/forum/sh...and-workaround

    In the meantime I will report the bug to the developers as well of course.

    Thanks,
    Michael
    QA Engineer, Lightworks

  8. #8
    Join Date
    Oct 2019
    Posts
    3

    Default

    Thank you, that fixed the issue for me.

  9. #9
    Join Date
    Dec 2017
    Posts
    300

    Default

    In the latest Iray+ plugin build I have a lot of problems with this old bug.
    Workaround is not helping at all.
    This sucks:

    Click image for larger version. 

Name:	bad-black-geo.jpg 
Views:	59 
Size:	261.2 KB 
ID:	10820

    Best!
    Nik

  10. #10
    Join Date
    Dec 2017
    Posts
    300

    Default

    And this seems to depends of camera angle - if I rotate objects a bit - it could fix issues, but still ....

    Best!
    Nik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •