Results 1 to 9 of 9

Thread: Some MDL mats textures are missing in IrayServer with Iray+ 2

  1. #1
    Join Date
    Dec 2017
    Posts
    227

    Default Some MDL mats textures are missing in IrayServer with Iray+ 2

    I have experience a problems with missing textures on some objects when I sent them to Iray Server.
    They are MDL's from vMaterials.
    Before with Iray+ 1.9 I haven't any problems with that.
    Even with beta 2 there was no problems.
    But now I can't use many of MDL materials from vMaterials collection.

    This is major problem here for some scenes.

    Example MLD mat that have a problem now - Teak - Deckling.
    I will repeat - I had no problems before Iray+ 2.0.

    Best!
    Nik

  2. #2
    Join Date
    Nov 2017
    Posts
    219

    Default

    Hi Nik,

    You say you had no problems with v2 beta? Do you know which version of the beta was working for you? We released different versions - one was using Iray 2018.0.2 and one was using Iray 2018.1.2.

    Michael
    QA Engineer, Lightworks

  3. #3
    Join Date
    Dec 2017
    Posts
    227

    Default

    It was with Iray 2018.1.2 with 3ds Max 2019.
    Now I work in 3ds Max 2021/20 with latest Iray+ build - from a couple of days before.

    Best!
    Nik

  4. #4
    Join Date
    Nov 2017
    Posts
    219

    Default

    Hi Nik,

    v2.0 (and v2.0.1) are still using Iray 2018.1.2, so if you are still using the same version of Iray Server then there should be no differences as far as the Iray rendering and the connection to the server is concerned.

    However, I note you have also switched Max versions. Is it possible you do not have the same texture paths and/or MDL paths set as you had when using 3ds Max 2019? Do you see the textures when rendering locally?

    Thanks,
    MIchael
    QA Engineer, Lightworks

  5. #5
    Join Date
    Dec 2017
    Posts
    227

    Default

    Everything is rendering locally without any problems.

    I will try later to check with MAX 2019 the same scene and will tell you back.

    Edit - some of other MDL materials from that libary renders fine with Iray Server. Others - not.
    Paths are ok and they are the same same in all Max versions - as I use the same MDL materials and in settings for Custom MDL paths are is the same.


    Best!
    Nik
    Last edited by NikNastev; 24th June, 2019 at 12:04.

  6. #6
    Join Date
    Dec 2017
    Posts
    227

    Default

    I just checked in Max 2019 - the same result - textures missed in some MDL's.

    This scene was rendered just fine with previous version of Iray+ (probably 1.9, not 2.0).

    Best!
    Nik

  7. #7
    Join Date
    Dec 2017
    Posts
    227

    Default

    Ok, I found that failed MDL's to render - with missed textures have no texture slot in Material editor.
    MDL's that are rendering fine have texture slots in Material Editor - where you can choose textures and their paths.

    Could that be a problem?

    Screenshots:
    Click image for larger version. 

Name:	Plaster_ok.png 
Views:	4 
Size:	135.9 KB 
ID:	10698Click image for larger version. 

Name:	Teak_failed.png 
Views:	3 
Size:	149.4 KB 
ID:	10699

    Best!
    Nik
    Last edited by NikNastev; 24th June, 2019 at 12:23.

  8. #8
    Join Date
    Nov 2017
    Posts
    219

    Default

    Hi Nik,

    I have reproduced the problem here with the same materials. Plaster is looking okay, but Teak - Decking has no materials. I will have a look at this.

    Thanks for reporting,
    MIchael
    Last edited by MichaelBellamy; 24th June, 2019 at 14:09.
    QA Engineer, Lightworks

  9. #9
    Join Date
    Dec 2017
    Posts
    227

    Default

    Thank You!

    Best!
    Nik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •