Results 1 to 10 of 10

Thread: Iray Lights Not Appearing in Iray 'Light Objects' Panel,

  1. #1

    Default Iray Lights Not Appearing in Iray 'Light Objects' Panel,

    Often I have come across the issue of recently-added [edit: Iray] lights not appearing in the Iray 'Light Objects' panel. They'll show up in Rhino's 'Lights' panel, but I'm dubious of editing anything in that panel due to previous conflicts.

    At first I thought it was an issue w/ larger files, but this is not a big one.

    Eventually they show up, but maybe I need to restart RH6, open/close the Panel, whistle a certain melody...

    Any suggestions?

    RH6, iray1.5.331

    Click image for larger version. 

Name:	IrayLightObjectsPanel.png 
Views:	42 
Size:	102.2 KB 
ID:	10427


    Thx in advance,
    -dt
    Last edited by dtmurcielago; 9th May, 2018 at 18:40. Reason: clarification

  2. #2
    Join Date
    Dec 2017
    Posts
    121

    Default

    I believe this issue was actually a Rhino bug, if you update to the latest SR it should be okay.

  3. #3
    Join Date
    Jan 2018
    Posts
    4

    Default

    I remember seeing this issue when I was using certain emissive materials in Rhino. For example, when using the "Add thermal emission" material, this lead to a broken light list. Can you check whether you are using this material in your scene?

    All the best,
    Rüdiger

  4. #4

    Default

    Quote Originally Posted by ruediger View Post
    I remember seeing this issue when I was using certain emissive materials in Rhino. For example, when using the "Add thermal emission" material, this lead to a broken light list. Can you check whether you are using this material in your scene?

    All the best,
    Rüdiger
    Thx for the input, Rudiger!
    Yes, the 'Add thermal emission' material was present at one point in the model/mat'ls palette, as it was new & i wanted to try it, but only 'Add emission' is currently present & in-use, along with 'display'.
    (sorry for the delayed reply, I've been out of town & away from my workstation.)

  5. #5

    Default

    Quote Originally Posted by jcarruthers View Post
    I believe this issue was actually a Rhino bug, if you update to the latest SR it should be okay.
    Def could be.
    Ok.
    Will do (I've been out'a town);
    --but I was using updates = daily-builds for a bit and/or SR-release candidates generally, so not sure if a SR would have been more current.
    Now updated to 6.5.18149.14421, 5/29/2018...
    --negative: i just did a test & don't see my new spot in the list (generally new lights are listed in order created, so checking the bottom... would also be nice to sort list by 'type', name, etc...)
    If I save, close, and re-open it would likely appear, but the project has since been delivered, and I want to keep the file in its current archival condition for now.

    Thx,
    -dt

  6. #6

    Default

    Click image for larger version. 

Name:	LightObjectsPanels.png 
Views:	23 
Size:	213.5 KB 
ID:	10469

    --once i restart Rhino, the lights appear in Iray Light Objects panel...

  7. #7
    Join Date
    Dec 2017
    Location
    Melbourne, Australia
    Posts
    350

    Default

    I do not reproduce, can you give simple, exact steps you are following.

  8. #8

    Default

    Quote Originally Posted by Paul View Post
    I do not reproduce, can you give simple, exact steps you are following.
    --Let me get back to you on that, Paul -- I've tried some simple proofs & can't seem to recreate the issue, tho I've had it in multiple projects for quite some time.
    In the case above, I just inserted an Iray Spotlight & copied it several times.

    RH6 did recently update, so maybe McNeel fixed something? I'll let you know if I see it again--hopefully I won't! .

  9. #9

    Default

    Paul - It happened again. Best guess is something to do with large model size. I'm at 111MB, w/ a few blocks. Memory, etc are all normal (e.g. not maxed out).

    I'm literally just clicking on the 'Spot Light' tool under the 'Iray Lights' tab & manually placing a single spot light. The light is on its own layer '0-Lights.' Nothing fancy nor intricate. Just one light.

  10. #10
    Join Date
    Dec 2017
    Location
    Melbourne, Australia
    Posts
    350

    Default

    Just to close this out, it was fixed in the .376 release.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •