Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: IMF 2017 : MDL Automotive Glass

  1. #1
    osc Guest

    Default IMF 2017 : MDL Automotive Glass

    Hi,

    Is there an issue with that material ?
    Click image for larger version. 

Name:	Vitre IFM Maya 2017 réduit.png 
Views:	94 
Size:	521.5 KB 
ID:	8656

    Thank you,

    Olivier

  2. #2
    rossh Guest

    Default

    Yes, this appears to be a bug. Should be fixed in the next release of the plugin.

  3. #3
    rossh Guest

    Default

    Actually it isn't a bug, you just have to make adjustments in your scene to work with the scene units you are using.

    We have a Legacy option in Iray Common render settings tab, Ignore scene units. This will work but it's really just for making older scenes still work as is after we fixed a bug with scene units.

    But the correct way is to set the Advanced Clarity value in the Automotive_Glass (or if using an ifmDielectric material, the Volume Scale). Set the value to the number of Metres* per MANY unit. so for instance, if you are using CM, set this value to 0.01 (100cm to the metre). Then the saturation should work as expected...

    *Metre - international spelling if you are from the US. ;-)

  4. #4
    osc Guest

    Default

    Hello,

    I couldn't set Clarity to 0.01. I can only adjust the parameters with the slider, not by typing the value (except for integers)... And the slider's minimum Clarity value is : 0.1
    That problem occurs with all the mdl material parameters : integers are the only values I'm allowed to type ; float numbers are rejected...

    So, last about the automotive glass rendering, the glass remains transparent if there is no object behind...Is that a bug ?

    Thank you,

    Olivier
    Attached Thumbnails Attached Thumbnails AutomotiveGlass.png  

  5. #5
    cberndt Guest

    Default

    Hi Oliver,

    which version of Iray for Maya are you using? I'm testing it with the last release (IrayForMaya 2016 Release 93 -> see it in Maya Output Window after the plugin is loaded) and there I can set the Clarity attribute to 0.001.

    Please can you explain to me what you mean by: "So, last about the automotive glass rendering, the glass remains transparent if there is no object behind". I'm not sure what you mean by that.

    Regards

    Chris

  6. #6
    osc Guest

    Default

    Hi Chris,

    I will check the release this evening.
    By "transparent when no objects behind" I mean the glas only shows green reflects on the yellow sphere and on the brick floor, and not on the grey background. I would show I guess if there was a grey wall behind, instead of the background.

    Regards,

    Olivier

  7. #7
    osc Guest

    Default

    Hi Chris,

    I'm in release 73 and when I check for updates, the nVidia Prof. Appl. Center doesn't propose me any...

    Olivier

  8. #8
    fuchs Guest

    Default

    Have you updated the PAC?

  9. #9
    tkollig Guest

    Default

    HI!

    I assume that you are using Maya 2017. Iray for Maya 2017 Release 73 is the latest version.

    Can you send the scene? I will look at it tomorrow.

  10. #10
    tkollig Guest

    Default

    First of all, I had already the issue that typing ".1" doesn't work in Maya and I had to type ",1" . I think it's a language setting. Furthermore have you tried to type e.g. a parameter of a transform node with a floating number?

    I assume that you get these greenish tone because you have a simple plane. the material automotive_glass seems to be (haven't rechecked it in the MDL code) for real modelled glass, i.e. it has to have a thickness. If this material is used on a simple plane, each refracted ray will be handled as inside the material until it hits - may be after a lot of scatter events - the plane again.

    Exchange the simple plane with a thin cube, and you will get the desired result.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •